Sirius

2008年10月28日(火) 23:40

yum が動かない

最新にした FC7 で、Samba を使おうと思い、yum でインストールしたら yum がハングアップしたようです。
ハングアップ以外もどうもおかしい。libjpg や libtiff を従属インストールしようとする。なんで Samba に libjpg や libtiff が必要なんだろう。

とにかく yum ではインストールできないので 直接ダウンロードして、rpm でインストールを試みました。
しかし、rpm でもとまってしまうようです。rpm でデバッグ情報を出力させてみたら、どうやらデータベースを読みに言ったところでとまっているようです。

調べたら、yum はたまに rpm のデータベースを壊すことがあるようです。
と、いうことで rpm のデータベースを再構築。
# rpm --rebuilddb

ちょっと時間がかかりましたが再構築できたようなので yum で Samba のインストール。
今度はちゃんとインストールできました。やはり libjpg とかはいらないようで今回は従属インストールの中には入っていませんでした。

これは、ひょっとすると、Fedora8 にアップグレードできるかもしれません。

written by sirius [玄箱] [この記事のURL] [コメントを書く] [コメント(0)] [TB(0)]

この記事へのトラックバックPingURL

Comments

TrackBacks

Sirius

MySketch 2.7.2 written by 夕雨