Raspberry Pi OS のアップグレード(CDEmu)

 Raspberry Pi OS のアップデートをしました。

$ sudo apt-get update
$ sudo apt-get upgrade -y

 kernel がアップグレードされましたが、kernel バージョンは変わりません (5.10.17-v7l+) でした。ただ、日付は、2/22 から 4/30 に変わっていました。また、bootloader も更新されたようです。一応再起動します。

$ sudo reboot

 kernel のバージョンが変わらなかったので、CDEmu の vhba モジュールはそのままで動くかと思ったのですがロードされませんでした。

$ lsmod | grep vhba
$ sudo modprobe vhba
modprobe: FATAL: Module vhba not found in directory /lib/modules/5.10.17-v7l+
$ ls /lib/modules/5.10.17-v7l+/extra
vhba.ko

 モジュールはあります。

$ sudo depmod -a
$ sudo modprobe vhba
$ lsmod | grep vhba
vhba 20480 0

 depmod が必要だったようです。

 

Raspberry Pi

Posted by sirius